Linux: Wireguard module build failed

0

Wireguard lässt sich nicht starten. Es wird dabei folgender Fehler im syslog protokolliert:

[...]
ip link add dev wg0 type wireguard
Error: Unknown device type.
[...]

1. Prüfen ob wireguard module geladen wurde

$ modprobe wireguard
modprobe: FATAL: Module wireguard not found in directory /lib/modules/5.4.83-v7l+

Sieht nicht danach aus.

2. DKMS Status prüfen

$ dkms status
wireguard, 1.0.20201221, 5.4.83+, armv7l: built

Module ist nicht verfübgar. Korrekter Status sollte sein

wireguard, 1.0.20201221, 5.4.83+, armv7l: installed

3. Linux headers installieren

$ apt install raspberrypi-kernel-header

4. dkms module bauen

$ dkms status
$ dkms build wireguard/1.0.20201221
$ dims install wireguard/1.0.20201221
$ modprobe wireguard
$ wg-quick up wg0

Wenn es immer noch nicht fluppt…

5. wireguard und kernel-header neu installieren

$ apt remove wireguard wireguard-dkms raspberrypi-kernel-headers
$ apt install raspberrypi-kernel-headers wireguard wireguard-dkms
$ wg-quick up wg0
Share.

About Author

Seit der Ausbildung zum Fachinformatiker Systemintegration (2002-2005) bei der DaimlerChrysler AG, beruflich im Bereich der E-Mail Kommunikation (Exchange, Linux) sowie des ActiveDirectory, mit entsprechenden Zertifizierungen (MCSE 2003, MCITP Ent.-Admin 2008, MCSE 2012, LPIC 1-3) tätig. Abgeschlossenes Studium zum Master of Science IT-Management an der FOM sowie zertifizierter Datenschutzbeauftragter. Aktuell als Teamleiter tätig.

Leave A Reply