sa-learn Probleme nach Upgrade auf Debian 4.0

0

Nachdem ich zwei Server von Debian Sarge 3.1 auf Debian Etch 4.0 geupdatet habe bekam der Admin bei cron Lauf der die Option sa-learn –sync vorsieht folgende

eMail:bayes: expire_old_tokens: locker: safe_lock: cannot create tmp lockfile /var/spool/spamassassin/bayes.lock.server.tld.10173 for /var/spool/spamassassin/bayes.lock: Keine Berechtigung

Reproduzieren lässt sich der Fehler durch ein manuelles starten von /usr/sbin/amavisd-new-cronjob sa-sync unter dem Account von amavis (su amavis).

Lösung: 

groupadd bayes_users
mkdir /var/spool/spamassassin/
chown root:bayes_users /var/spool/spamassassin/
chmod 0770 /var/spool/spamassassin/
adduser amavis bayes_users
Teilen.

Über den Autor

Seit der Ausbildung zum Fachinformatiker Systemintegration (2002-2005) bei der DaimlerChrysler AG, beruflich im Bereich der E-Mail Kommunikation (Exchange, Linux) sowie des ActiveDirectory, mit entsprechenden Zertifizierungen (MCSE 2003, MCITP Ent.-Admin 2008, MCSE 2012, LPIC 1-3) tätig. Abgeschlossenes Studium zum Master of Science der IT-Management an der FOM sowie zertifizierter Datenschutzbeauftragter. Aktuell im Projektmanagement tätig.

Antworten