amavisd-new: Benachrichtigung auf Deutsch

8

Die Statusnachrichten von Amavisd-new werden nach der Grundinstallation immer auf Englisch versandt. Um diese auf Deutsch um zu stellen, müssen zuerst die entsprechenden Dateien herunter geladen werden. Uwe Drießen hat auf seiner Seite freundlicherweise eine deutsche Übersetzung bereit gestellt: http://fblan.de/postfix/amavis/. Diese können wie folgt herunter geladen werden.

mkdir /etc/amavis/de_DE
cd /etc/amavis/de_DE
wget http://fblan.de/postfix/amavis/de_DE/charset
wget http://fblan.de/postfix/amavis/de_DE/template-dsn.txt
wget http://fblan.de/postfix/amavis/de_DE/template-spam-admin.txt
wget http://fblan.de/postfix/amavis/de_DE/template-spam-sender.txt
wget http://fblan.de/postfix/amavis/de_DE/template-virus-admin.txt
wget http://fblan.de/postfix/amavis/de_DE/template-virus-recipient.txt
wget http://fblan.de/postfix/amavis/de_DE/template-virus-sender.txt

Anschließend muss in der Datei /etc/amavis/conf.d/30-template_localization folende Zeile ergänzt werden:

read_l10n_templates('de_DE', '/etc/amavis');

Die Zeile für en_EN muss auskommentiert werden. Nach einem Neustart von amavisd-new werden anschließend die Statusnachrichten auf Deutsch versandt.

Links:

Teilen.

Über den Autor

Seit der Ausbildung zum Fachinformatiker Systemintegration (2002-2005) bei der DaimlerChrysler AG, beruflich im Bereich der E-Mail Kommunikation (Exchange, Linux) sowie des ActiveDirectory, mit entsprechenden Zertifizierungen (MCSE 2003, MCITP Ent.-Admin 2008, MCSE 2012, LPIC 1-3) tätig. Abgeschlossenes Studium zum Master of Science der IT-Management an der FOM sowie zertifizierter Datenschutzbeauftragter. Aktuell im Projektmanagement tätig.

8 Kommentare

  1. Die Dateien sind wieder online waren beim Umzug des Servers nicht wieder in die Veröffentlichung gewandert.

    wenn sowas passiert kurze mail dann wird das auch wieder zur Verfügung gestellt.

  2. Irgendwie bekomm ich mit diesen Templates einen Fehler in der "an:" Zeile.

    "MISSING_MAILBOX@SYNTAX_ERROR "

    Email kommt zwar an aber eben ein schönheitsfehler.
    Der Syntax der darin verwendet wird ist mir aber schleierhaft.

    Einer eine Lösung ?

  3. Christian Scholz am

    Hallo Frank,

    hast Du die Templates mittels wget heruntergeladen oder per copy & paste übernommen? Ich tippe ad-hoc auf einen Problem bei der Zeichencodierung. Bei copy & paste gibt es immer wieder Probleme mit den Zeilenumbrüchen.

    Ich habe Dir die Templates noch einmal extra gepackt per E-Mail geschickt. Schau bitte einmal, ob das Problem damit auch besteht.

    Gruß Christian

  4. Hallo Christian,

    Hab die Templates per "Hand" kopiert.
    mittels vi und insert. Denke nicht das ich hier etwas mitkopiert habe das ich nicht will.

    Der "To:" teil ist im übrigen gleich wie bei den bereits hier online gestellen Files.
    Ich wer das das mit den Umbrücken also cr oder lf nochmal überprüfen.

    danke erstmal !

  5. achso ich muss noch anmerken das ich den teil

    Anschließend muss in der Datei /etc/amavis/conf.d/30-template_localization folende Zeile ergänzt werden:

    read_l10n_templates(‘de_DE’, ‘/etc/amavis’);"

    bei mir nirgends gefunden habe.

    (Centos 6.5, amavisd-new-2.8.0)

Antworten